Ask a Question

An error occurred while resolving packages in Unity- missing xcrun

An error occurred while resolving packages: Project has invalid dependencies: com.cysharp.unitask: Error when executing git command. xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun com.metafab.sdk: Error when executing git command. xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun A re-import of the project may be required to fix the issue or a manual modification of /Users/isaactut/demos/ProjectGlichFlight/Packages/manifest.json file.

tried to set up eco system

was distracted after i set up the new name, but didn't copy any of the information down. I thought I'd still be able to use the old secret key since i didn't change passwords or email or anything. The program won't let me start over because it note an ecosystem with that email ha already been created. I'm assuming there's a new secret key. What to do?

Help with redirect Uris issue?

I have been going along with the MetaFab Demo video that had been posted onto Youtube and everything up to 32:23 has worked as mentioned in the video. I placed the same bridgeworld URL in the redirectUris as exactly as you shown, I clicked on the "Try It" button on the Curl window and I recieved a 200 response message with my game data information I entered. Now with the 200 response message, I am assuming my informtion is correct but when I go to try it out on my connect.metafab.com page and login, it continues to hourgass and not redirect. We have also tried using other links besides bridgeworld and the redirects have not worked for me, my friend, or my father and we're all recieving the same outcome. We continued to work through the video numerous times to gain knowledge of other functions and have created in-game tokens succesfully. We would like some help with the redirect, would someone please assist us with the redirectUris?

Not Able To Create Custom RPC

I am using the PATCH /v1/games/{gameId} to set my custom rpc, but when i do i get "X-Game-Access-Token invalid for game id my published key". I am assuming the game id is the same as the publishedkey. Please help me know what i may be doing wrong

Issue When Creating A Currency

hi so i'm using the example in the unity sdk github page to try and create a currency. But whenever it gets to the creating the currency i get the error : UnityWebRequestException: HTTP/1.1/ 504 Gateway Timeout. but requesting for various data works. I tried using the create currency endpoint but it keeps too long.

How to send native token to wallet id

so how do i send a native token like matic or test matic to the wallet id for currency or item creation?. That instruction is not clear

How to I make a MetaFab Game?

Reference: In the: Create a Game Currency topic Step 1: Get your Game's credentials If you've followed the >>Create a MetaFab "Game"<< guide, you're good to go - you should have a set of Game credentials that look something like this. The Create a MetaFab "Game" is a link to the following address: https://docs.trymetafab.com/docs/create-a-metafab-game Returns a 404 error. How to I make a MetaFab Game?

This is the firts question !

Hello, just want to port the first question. Thank you for your incredible job, exited for the futur !